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Using Geometer’s Sketchpad 4:  Some Basics 

 
This handout describes some of the basic geometric notions and constructions 
built into the Geometer’s Sketchpad (GSP) software. Please explore the basic 
tools and relationships as you read. 
 
The Tool Box 
The best place to begin is to note the basic tools that appear in the vertical 
toolbox: the select tool, the point tool, the circle tool, the segment-ray-line tool, 
and the ‘create/use’ tool. Click on a tool to make it active. 
 The Select Tool (symbolized by an arrow on the toolbar and as a cursor) is 

the most used tool, and is used to select objects; click-&-drag a marquee to 
select all inside to act as a “group”; you DEselect specific objects by clicking 
on them, or all objects by clicking anywhere in the white sketch field; 

 the Point Tool places points; 
 the Circle Tool creates circles with a click-&-drag operation; the first click 

locates the center, then drag out from center and release to create another 
“control point” that is actually the end of the defining (but invisible) radius; 

 the Straight Object Tool, like the circle tool, uses a click-&-drag operation 
to give each segment, ray or line two “control” points. 

 The Label/Text Tool appears as an “A” on the vertical Toolbox. When this 
tool is selected, the pointer takes on the form of a hand. 
  Moving it sufficiently close to an object turns it from a white to a black 

hand, and it will act as a show/hide switch for the object’s label. 
  When the hand is sufficiently close to a label, an “A” appears inside the 

hand; double-clicking then will allow you to edit (change) the label to 
whatever you’d like, and to change the font style. 

  Click-&-drag to create a text box anywhere on the field. 
  You can Hide or Show the Text Palette via the Display menu. Highlight 

an object to change the font, size and color of the object’s label. Highlight 
text directly to change its appearance. 

 
If you make a mistake you can 
 use [Edit > Undo] to undo as many steps as you like; [Edit > Redo] is also 

available, so you could repeatedly undo and redo a construction or 
movement, allowing a sort of “instant replay”; 

 select an object and use [Edit > Cut], or use the “Delete” or “Backspace” key; 
 
Quick Overview of Menus 
To get an overview of the breadth of GSP’s capabilities, move across the top 
menu bar and click to reveal the sub-menus under each menu category. 
 
GSP is the Grandaddy of “dynamic geometry” software 
GSP is described as “dynamic” geometry software because relationships 
that are constructed remain intact even when objects are moved around. 
For example, use the segment tool to create a segment. Select the segment and 
use [Construct > Midpoint]. Drag either endpoint and note how the midpoint 
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dynamically remains in the middle of the segment. You can make the midpoint 
more obvious by selecting it, then [Display > Color > (pick one)]. 
 

In GSP constructions, there is the idea of a “parent–child” relationship. In 
the example above, the midpoint is a child of the segment, and the segment is a 
child of the endpoints. If you delete either of the endpoints then both the 
segment and the midpoint also get deleted. If you wanted to keep only one 
endpoint and the midpoint showing, you could select the segment and the 
other endpoint and use [Display > Hide**]. Click-&-drag the remaining 
endpoint around, and describe the motion of the midpoint. 
Select the two points and use [Display > Trace Points] to leave a trace of the 
movements, then use [Display > Erase Traces]. You must select the points 
again, and use [Display > Trace Points] again to turn tracing off. 
 

(** If you accidentally hide objects you didn’t intend to, use [Display > Show All 
Hidden]; deselect what you want to remain visible, and then use [Display > 
Hide] to hide what you want hidden.) 
 
More GSP Basics 
To measure an angle -  Select three points as if you were using them to name 
the angle, with the vertex in the middle; use [Measure > Angle]. As you make 
the measurement, the labels for the points will automatically appear on-screen, 
in alpha order. 
 

Dynamic Calculations -  The 
image shows the dynamic sum of 
two angles; this was done using 
the calculator in the Measure 
menu, and selecting, in order: 
mABC, “+”, mABCD, “OK”. 
 

To Construct a Polygon Interior 
-  Select the vertices 
IN ORDER; use [Construct > 
Polygon Interior]. When the area 
is constructed, it is selected 
(shown by cross-hatching) and 
given the last color selected. While 
an area is selected, you can use 
[Measure] to find the area or 
perimeter. 
 

To Construct the Diameter of a 
Circle:  Construct a ray defined 
with its endpoint on the circle and 
using the center as the second 
defining point for the ray. Construct the point of intersection of the circle and 
the ray, using the select arrow or as a construction. Use the segment tool to 
construct the diameter. Hide the ray if you like. 
 

Toolbox Text 
Palette 
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To Construct a Circle Interior -  Select the circle; use [Construct > Circle 
Interior]. You can select a circle and measure its circumference, area and 
radius even without constructing the interior.  
 

To Construct an Arc:  Select the circle and the two desired arc endpoints in 
COUNTERCLOCKWISE order; [Construct > Arc]. 
 
Constructing Transformations 
A transformation is an operation that maps a point or figure in a particular 
way. There are three basic transformations that map a figure without changing 
its size or shape. Each of these isomorphic transformations (iso = same; morph 
= shape) are described below with a correct name (and nickname), and an 
associated ‘reference’ elements that must be identified. An additional 
transformation is described that preserves the shape of the original, but not 
necessarily the size. 
 
 A reflection (‘flip’) 

requires a ‘Mirror’: select 
a straight object, then 
[Transform > Mark 
Mirror]; you can also 
double-click on the 
object to get the 
“bulls-eye” animation 
denoting it was 
marked as a 
transformation tool. 
Select the objects to 
be reflected, then use 
[Transform > Reflect]. 
A ‘preview’ of the 
image appears before you 
actually commit to the 
transformation. In the 
figure to the right, point 
X and the bottom 
endpoint of the “S” were 
reflected through 
segment PQ. The points 
were assigned colors (red 
and blue), and [Display > Trace] was used to spell out “Shelly” and, 
simultaneously, the reflection. 

 

 A rotation requires a ‘Center’ and an angle: select a point, then [Transform 
> Mark Center], or double-click on the point to get the “bulls-eye” animation 
denoting it was marked as a center. Select the objects to be rotated, then 
use [Transform > Rotate]. Use the Fixed Angle that you type in, or you could 
mark an angle in the sketch as the determining angle of rotation. Again, a 
‘preview’ shows where the image will be, as shown in the figure above. 
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 A translation requires a ‘Vector’: select two points, IN ORDER, that will 
define the direction and length of the vector, then [Transform > Mark 
Vector]; you will see an animation denoting that the path was marked as a 
translation vector. Select the objects to be translated, then use [Transform > 
Translate]. 

 

 A dilation requires a ‘Center’ and a ‘Ratio’ or ‘Scale Factor’: select a point, 
then [Transform > Mark Center], or double-click on the point to get the 
“bullseye”. Select the objects to be dilated, then use [Transform > Dilate]. 
You can use By Fixed Ratio, and enter numbers as numerator and 
denominator of the ratio, or define the scale using objects in the sketch. As 
with the other transformations, a ‘preview’ is shown as a shadow. 

 
Constructing Basic Polygons  
Constructing Triangles - 
A scalene triangle has no two 
sides equal, and is the most 
general type of triangle since it 
has no special properties. 
You can construct a scalene 
triangle by simply using the 
segment tool.  
 

An isosceles triangle has at 
least two sides equal. The 
equal sides are called legs 
and the other side is the 
base. The legs meet to form 
the vertex of the triangle. 
You could construct an 
isosceles triangle by using 
two radii of a circle as the 
legs, and connecting their 
endpoints that are on the circle 
to be the base.  
 

A right triangle has a right 
angle. You could construct a 
right angle by joining the 
endpoints of a diagonal to any 
point on the circle. 
 

 
Constructing Special Polygons - 
It is the simplicity and symmetries of the regular polygons that makes them so 
compelling, and so important in nature, the arts, and the sciences. Many of 
them can be constructed directly using compass and straight-edge, as well as 
using a variety of combinations of transformations. Some examples of 
construction strategies are given for the following polygons.  
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Constructing Regular Polygons - 
Note: “(A, AB)” represents “the circle with center A and radius AB”. 
 
Regular Triangle  
Transformational Construction:  
•  Begin with a segment AB. 
•  Rotate the segment through 60° in opposite directions (clockwise and 

counter-clockwise) about each of the endpoints. 
 

Euclidean Construction:  
•  Use the circle tool to construct (A, AB) 
•  Construct (B, AB). The central “eye” or football shape in such a 

construction is called a Vesica Pisces. 
•  Select the points A and B; Display >> Color these points to distinguish them 

later. De-select the points, then change the color back to (the default) red. 
•  Connect A, B and either of the endpoints of the Vesica to form a triangle. 

How would you confirm that this triangle is regular or not? 
 

Square  
Transformational Construction:  
•  Begin with a segment AB. 
•  Rotate the segment 90° clockwise, centered about endpoint A. 
•  Connect to form the segment joining B to it's image, B’. 
•  Reflect AB and AB’ over the mirror BB’. 
 

Euclidean Construction:  
•  Construct a pair of perpendicular lines, intersecting at point A. 
•  Construct a circle centered at the point of intersection of the lines, A, and 

intersecting one of the lines at B. 
•  Connect the four points of intersection of the circle with the lines to 

construct a square with center A and control point B. 
 

Other Regular Polygons  
Can you describe at least one transformational and one Euclidean construction 
strategy for the regular pentagon and regular octagon? Are there patterns 
governing these strategies?  
 

Constructing Other Special Polygons - 
Parallelogram  
Transformational Construction:  
•  Begin with a segment AB. 
•  Place a point C somewhere on the plane. 
•  Use the segment tool to create segment AC. 
•  De-select, and then select, in order, A and then C. Transform >> Mark 

Vector. 
•  Select segment AB. Transform >> Translate >> Marked Translation Vector. 
•  Similarly, mark A to C as a vector, and translate segment AC along vector 

AB. 
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Euclidean Construction:  
•  Construct segments AB and AC. 
•  Select segment AB and point C; 

Construct >> Parallel Line (shown 
here in pink). 

•  Similarly, construct the line 
parallel (in pink) to AC passing 
through B. 

•  The point of intersection of the 
constructed parallels, point X, 
provides the fourth vertex of a 
parallelogram ABXC. 

 
 
Other Types of Polygons  

Can you describe at least one 
transformational and one Euclidean 
construction strategy to construct:  
 a rectangle? 
 a rhombus? 
 an equilateral but non-regular pentagon? 
 a figure that exhibits rotational symmetry but not line symmetry? 
 a figure that exhibits line symmetry but not rotational symmetry? 
 
 
Creating Tessellations 
Tessellations can be generated using combinations of reflections, rotations and 
translations. 
Here is a set of directions to generate a simple tessellation that starts with a 
square and uses only translations. 
 Start with square ABCD. 
 In order, select points A then D; use [Transform > Mark Vector], and an 

animation will illustrate a horizontal vector. 
 Place a point X somewhere between A and B just outside of the square, and 

construct segments AX and BX. (fig #1) 
 Select segments AX and BX and point X; use [Transform > Translate]. 
 In order, select points A then B; use [Transform > Mark Vector], and an 

animation will illustrate a vertical vector. (fig #2) 
 Place a point Y somewhere between A and D just outside of the square, and 

construct segments AY and DY. (fig #3) 
 Select segments AY, DY and point Y; use [Transform > Translate]. (fig #4) 
 Select the entire figure. Use [Transform > Translate] to get a vertical double. 

(fig #5) 
 Define a horizontal vector from A to D. Select the ‘stack’ of two figures and 

use [Transform > Translate] to get the set of four figures. (fig #6) 
 Can you describe what was done to get fig #7? 

[SEE ILLUSTRATION ON NEXT PAGE.] 



Using Geometer’s Sketchpad to Support Mathematical Thinking 
 

 

Shelly Berman p.7 of 11 Jo Ann Fricker 

 

 
 
 
Creating Animations 
GSP-4 allows you to animate objects. This 
is extraordinarily useful in developing ideas 
of dynamic relationships. For example, you 
can animate a point along a line parallel to 
the base of a triangle to show that it does 
not change the area of the triangle 
(Cavalieri’s Principle). In this example, P is 
animated to move back and forth along the 
line, and we can show or hide the values 
for the measured quantities. 
 
Creating Custom Tools 
In GSP-4, you can create custom tools. For example, we could create a 
“perpendicular bisector” tool: construct a line segment; select the segment and 
use [Construct >> Midpoint]; select both the segment and the midpoint, and 
[Construct >> Perpendicular Line]. To make the bisector itself distinct, use 
[Display >> Color >> Red]. 
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To turn this construction into a tool: 
•  select the segment, midpoint and 

perpendicular (you can ‘marquee’ the 
area by using click-&-drag of the select 
tool); 

•  use [Custom Tool >> Create New]; this 
will bring up a prompt for a “New Tool 
Name”; use “PerpBisector”, and click 
“OK”, which closes the dialog; 

•  selecting the Custom Tool will show an 
option for “This Document:”, which leads 
to our new PerpBisector tool. Using the 
tool will generate segments that show 
their perpendicular bisectors in red; 

•  in GSP-4, once a document is opened, 
any tools defined in that document are 
actively available for any other open 
document; 

•  if you want the tool to always be available either leave the original document 
open when opening a new sketch, or use the PerpBisector tool in a new 
document, then use [File >> Save As] to save the document into (GSP >> 
Tool Folder) as “PerpBisector”; 

•  once you quit and re-start GSP, this tool will be available in the Custom 
Tool menu. 

 

Note that all of this information is available in the document: 
(Samples >> Custom Tools >> Sample Tools .gsp). In fact, there are quite a 
variety of useful tools in the (Samples >> Custom Tools) folder. If you move the 
Custom Tools folder into the (GSP >> Tools Folder), and restart GSP, ALL of the 
Custom Tools will be available ALL of the time. 
 
I urge you spend time exploring the tool samples as one important way to 
develop a sense of how GSP can be useful. 
 
Creating a Dynamic Function Plotter 
You can use the GSP to graph functions with parameters that are controlled by 
“sliders”. A parameter is a value that may take on different values, but doesn't 
vary once it is set. For example, in the linear function   y = M•x + B ,  M and B 
are parameters, while x and y are variables. 
You will need a separate slider to control each parameter in an equation. 
 

1. Open a new sketch. Go to Edit >> Preferences >> Text >> As Objects Are 
Measured; set the Distance units to inches. 

 

2. Get two sliders from the Custom Tool menu, if they are already there. If 
Sliders is not there, open Sketchpad >> Samples >> Custom Tools >> 
Sliders.gsp. Leave that document open, and return to your original sketch. 
Sliders should now be available in the Custom Tools Menu under “Other 
Documents”. 
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3. When you open a slider it is “generic, and uses “a” as the parameter. The 
measure of “a” also shows. If you opened two sliders they are both labeled 
“a”. Use the measures to distinguish them. Use the label tool and double-
click to re-label the parameters as “Controls M” and “Controls B”; also re-
label their measures as “M” and “B”. 

 

4. Go to Graph >> Grid Form >> Square Grid. Notice that one point appears 
at the origin and another point appears at the unit (1) value on the x-axis. 

 

5. Using the Select tool, explore what happens when you click-&-drag the 
origin or the unit point. Change the grid type using Graph >> Grid Form 
>> Rectangular Grid. How many points show on the grid? What happens 
as you move each of them? 

 

6. Now lets create the basic function y = M•x + B. Use Graph >> Plot New 
Function to bring up a function “calculator”. Make sure that the Equation 
>> y = f(x) is showing. This means it is set up to get the right-hand side of 
the equation. 
Click once on the measure of M, which should make an “M” appear in the 
calculator screen. Click the key for “ * ” (multiplication), then the key for 
“x”; click “OK”.  

 

7. The expression “f(x) = M•x” should appear on-screen, and a line should 
appear on the grid. Move the drag point “M” on the slider, and describe 
what’s happening. 

 

8. If you want to edit a function’s equation, simply double-clicking on the 
function will take you to the function editor. 

 

9. Add the parameter B to make this a model for studying a general linear 
equation of the form  y = M•x + B ? Adding a third parameter would allow 
you to study equations of the form 
y = A•x2 + B•x + C ,  or  y = A•(x – H)2 + K . 

 

10. The calculator has a number of built-in functions, available under the 
Graph >> Plot New Functions >> Functions, including the three basic trig 
functions. How could you illustrate the effects of the parameters a, b and c 
in the general trig function   
y = A•sin(B•x) + C ? When you include a trig function, you will be 
prompted to think about changing the angle units from degrees to radians. 

 

11. The expression “f(x) = M•x” should appear on-screen, and a line should 
appear on the grid. Move the drag point “M” on the slider, and describe 
what’s happening. 

 

12. If you want to edit a function’s equation, simply double-clicking on the 
function will take you to the function editor. 

 

13. Add the parameter B to make this a model for studying a general linear 
equation of the form  y = M•x + B ? Adding more parameters would allow 
you to explore a variety of equations of the form. 
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14. After defining a function, say f(x) = mx + b, you can get the equation to 
dynamically show the value of parameters by following these steps: 
  activate the label/text tool and double-click in white space to make a 

text box; type in “=f(x)={1}•x+{2}”. (Note: use the mathematical symbols 
you get from the drop-down arrow at the right-hand end of the text 
palette); 

  select, IN ORDER, the text box described above and then the parameter 
value boxes (in the example you’d select the “m” first, then the “b”, etc.); 

  use [Edit > Merge Text] to get the dynamic equation. (Note: you can 
hide the “=f(x)= …” text box and or the literal equation, and just show 
the dynamic equation if you like; see example at bottom of this page.) 

 

15. Note that you can use the point 
tool to place a point on the 
plotted function, like point S in 
the illustration below, then use 
[Measure > Coordinates] to see 
the values change dynamically 
as you move point S. 

 

16. The calculator has a number of 
built-in functions, available 
under the Graph >> Plot New 
Functions >> Functions, 
including the three basic trig 
functions. How could you 
illustrate the effects of the 
parameters a, b and c in the 
general trig function   
y = A•sin(B•x) + C ? When you 
include a trig function, you will 
be prompted to think about 
changing the angle units from 
degrees to radians. 
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Importing GSP Sketches into a Word Document 
You can use GSP create graphics that can then be copied and pasted into 
documents, such as tests or other handouts. When you have figures that are 
completely visible, you just marquee the area around the figure and use [Edit > 
Copy] to copy this as a graphic – which is no longer dynamic. Then use [Edit > 
“Paste”] in Word. Highlight the graphic and use [Format > Picture > ...] to 
manipulate the layout, size, border and fill colors. 
 
At right is a figure that was  
in the second illustration. 
 
 
  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

The three figures above showing the purple 
perpendicular were all made from the same 
GSP sketch, using [Edit > Select All]; however, 
the border of each graphic shows the shape of 
the GSP window at the time the copy was 
made; notice the lines have arrowheads that 
go out to the border. GSP can also be used to 
create grids, or the illustrations like these 
that are part of the solution to the problem: 
“Given A (0,0) and B (3, 4), identify all 
possible locations for a 
point X so that ∆ AXB is 
isosceles.” 
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